summaryrefslogtreecommitdiffstats
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorndarshan <dnarayan@redhat.com>2014-03-17 12:21:42 +0530
committerBala.FA <barumuga@redhat.com>2014-04-29 10:14:32 +0530
commit686b574d3c1e55a778088b58a1a2fc75ce72d280 (patch)
tree89e6335b46c42dcea1c66e80cd7500059856ffd5 /plugins/Makefile.am
parentfcf78fd752dd24a8bb8b0bf8f62e7ba7ec0aac55 (diff)
plugins:Fix to handle sadf not accepting time range, test case addition
This patch handles the issue of sadf not accepting time range when used with -x (xml output) option(seen in version 9.0.4). Added unit-test for memory, cpu, swap, network plugins and refactored them. Change-Id: Ie7c2ecfbb38060f236a6faed606bce0aedd27d7a Signed-off-by: ndarshan <dnarayan@redhat.com> Reviewed-on: https://cuckoo.blr.redhat.com:8443/14 Reviewed-by: Bala FA <barumuga@redhat.com> Tested-by: Bala FA <barumuga@redhat.com>
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 2e2c03e..37da1cd 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -5,10 +5,14 @@ crond_DATA = \
dist_glusternagiosplugins_PYTHON = \
check_disk_and_inode.py \
+ cpu.py \
+ __init__.py \
+ memory.py \
+ network.py \
sadf.py \
+ swap.py \
$(NULL)
EXTRA_DIST = \
$(crond_DATA) \
- __init__.py \
$(NULL)