summaryrefslogtreecommitdiffstats
path: root/systemd/Makefile.am
diff options
context:
space:
mode:
authorJi-Hyeon Gim <potatogim@gluesys.com>2017-09-09 13:35:25 +0900
committerJi-Hyeon Gim <potatogim@potatogim.net>2017-09-21 19:30:27 +0900
commitfeb517ae133fd4af0dc35725070e80522ea43539 (patch)
tree51aa21a538139b495de5cb2a0b60daa94f086654 /systemd/Makefile.am
parent95db5c36b38fa883141cb3eeb237957d18091168 (diff)
dist: supports initd for non-systemd distros
Problem gluster-blockd supports systemd officially but many legacy distros want to use initd Resolve includes initd scripts for non-systemd distros Change-Id: I8495e8d9abbef6d26ac7dc8dbbe6d07e7713f537 Signed-off-by: Ji-Hyeon Gim <potatogim@gluesys.com>
Diffstat (limited to 'systemd/Makefile.am')
-rw-r--r--systemd/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/systemd/Makefile.am b/systemd/Makefile.am
index e1545db..798b4a8 100644
--- a/systemd/Makefile.am
+++ b/systemd/Makefile.am
@@ -1,13 +1,18 @@
-DISTCLEANFILES = Makefile.in gluster-blockd.service gluster-block-target.service
+DISTCLEANFILES = Makefile.in gluster-blockd.service gluster-block-target.service \
+ gluster-blockd.initd
-CLEANFILES = *~ gluster-blockd.service gluster-block-target.service
+CLEANFILES = *~ gluster-blockd.service gluster-block-target.service \
+ gluster-blockd.initd
-EXTRA_DIST = gluster-blockd.service.in gluster-block-target.service.in \
- gluster-blockd.sysconfig
+EXTRA_DIST = gluster-blockd.service.in gluster-block-target.service.in \
+ gluster-blockd.initd.in gluster-blockd.sysconfig
if USE_SYSTEMD
# systemddir is already defined through configure.ac
systemd_DATA = gluster-blockd.service gluster-block-target.service
+else
+# initddir is already defined through configure.ac
+initd_DATA = gluster-blockd.initd
endif
install-data-local: