summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPrashanth Pai <ppai@redhat.com>2013-11-06 17:30:28 +0530
committerLuis Pabon <lpabon@redhat.com>2013-11-17 16:34:11 -0800
commit991989bc04178442b2a6b766a67f7a26e60c08f0 (patch)
treee796215fbb45333290fdd293b608235b7f67493c /setup.py
parentf64a3354185f32928e2568d9ece4a52fa4746c05 (diff)
Modularize swift-auth CGI script, add unit tests
- Moved most of swift-auth CGI script to kerbauth_utils.py - Added unit tests for kerbauth_utils.py - Made MEMCACHE_SERVERS, DEBUG_HEADERS, TOKEN_LIFE as configurable parameters Change-Id: I2e9e9823e8aa99dc2cf41327c55428350c8768dc Signed-off-by: Prashanth Pai <ppai@redhat.com> Reviewed-on: http://review.gluster.org/6248 Tested-by: Chetan Risbud <crisbud@redhat.com> Reviewed-by: Chetan Risbud <crisbud@redhat.com> Reviewed-by: Luis Pabon <lpabon@redhat.com> Tested-by: Luis Pabon <lpabon@redhat.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 65aab59..d435a39 100644
--- a/setup.py
+++ b/setup.py
@@ -16,9 +16,10 @@
# limitations under the License.
from setuptools import setup
-from swiftkerbauth import __version__
import os
+__version__ = '1.0.0'
+
with open('README.md') as file:
long_description = file.read()
@@ -44,10 +45,10 @@ setup(
author='Red Hat, Inc.',
author_email='gluster-users@gluster.org',
long_description=long_description,
- url='https://forge.gluster.org/swiftkerbauth',
+ url='https://github.com/gluster/swiftkrbauth/',
packages=['swiftkerbauth'],
keywords='openstack swift kerberos',
- install_requires=['swift>=1.9.1'],
+ install_requires=['swift>=1.10.0'],
test_suite='nose.collector',
classifiers=[
'Development Status :: 3 - Alpha',