summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorPrashanth Pai <ppai@redhat.com>2013-09-24 11:47:50 +0530
committerLuis Pabon <lpabon@redhat.com>2013-10-16 15:49:12 -0700
commit373032fc97d27c79895e6114670760aa717f9f61 (patch)
treeecf027f06b2e00fd6605c148e831df806d10243f /setup.py
parent9812a4a9e4a30a208d77d3b10828a1c174dccd77 (diff)
Add documentation
The following guides were added: * Setting up a RHEL 6.x IdM server with a Fedora 18 client * Setting up and configuring swiftkerbauth * Architecture of Swiftkerbauth Change-Id: I50665e584ff9513b5a20d1eda546c73c93f14638 Signed-off-by: Prashanth Pai <ppai@redhat.com> Reviewed-on: http://review.gluster.org/6040 Reviewed-by: Luis Pabon <lpabon@redhat.com> Tested-by: Luis Pabon <lpabon@redhat.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 01210df..65aab59 100644
--- a/setup.py
+++ b/setup.py
@@ -19,6 +19,9 @@ from setuptools import setup
from swiftkerbauth import __version__
import os
+with open('README.md') as file:
+ long_description = file.read()
+
# Ugly hack to exclude data_files if running in tox as non root
def include_data_files():
@@ -40,6 +43,7 @@ setup(
license='Apache License (2.0)',
author='Red Hat, Inc.',
author_email='gluster-users@gluster.org',
+ long_description=long_description,
url='https://forge.gluster.org/swiftkerbauth',
packages=['swiftkerbauth'],
keywords='openstack swift kerberos',