summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorBala.FA <barumuga@redhat.com>2014-03-07 18:28:09 +0530
committerBala.FA <barumuga@redhat.com>2014-04-29 10:21:36 +0530
commit981d905fd08d4565f306344c11c560a8479cbf75 (patch)
tree7f0d0006ab7d7fbeea1e3e9e9a549280bd68a0a3 /tests/Makefile.am
parentfe7479d1c78555ee5f0dd219c690232c43c4938c (diff)
Initial commit
Change-Id: Iae865d7dce78de83f0931d99b67455b9a0f12e1c Signed-off-by: Bala.FA <barumuga@redhat.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..cc557cc
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,50 @@
+#
+# Copyright 2014 Red Hat, Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+#
+# Refer to the README and COPYING files for full details of the license
+#
+
+test_modules = \
+ $(NULL)
+
+dist_nagiosserveraddonstests_DATA = \
+ $(NULL)
+
+dist_nagiosserveraddonstests_PYTHON = \
+ $(test_modules) \
+ testrunner.py \
+ testValidation.py \
+ $(NULL)
+
+dist_nagiosserveraddonstests_SCRIPTS = \
+ run_tests.sh \
+ $(NULL)
+
+dist_noinst_DATA = \
+ run_tests_local.sh \
+ $(NULL)
+
+CLEANFILES = \
+ $(NULL)
+
+all-local: \
+ $(nodist_nagiosserveraddonstests_PYTHON)
+
+check-local:
+ @echo '*** Running tests. To skip this step place NOSE_EXCLUDE=.* ***'
+ @echo '*** into your environment. Do not submit untested code! ***'
+ $(top_srcdir)/tests/run_tests_local.sh $(test_modules)