summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThiago da Silva <thiago@redhat.com>2013-10-30 15:43:27 -0400
committerThiago da Silva <thiago@redhat.com>2013-10-30 15:48:24 -0400
commit3f2233ba01c74681ef565285a32fa8bcea8357e9 (patch)
treeb63daed43faa4cf520833d7521055ad1d237e36d /setup.py
parent055e0c6c65726da27e1c7e0ec0aaeaba507e1563 (diff)
initial repo tree with gfapi.py
This initial commit is a copy from gluster/api/examples/gfapi.py from the glusterfs repo Signed-off-by: Thiago da Silva <thiago@redhat.com> Change-Id: I4442528d5bc2ec52ed2970b818d8cb9327e36168
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py50
1 files changed, 50 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..fc396d0
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,50 @@
+#!/usr/bin/python
+# Copyright (c) 2013 Red Hat, Inc.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+from setuptools import setup, find_packages
+
+from gluster import __canonical_version__ as version
+
+
+name = 'gfapi'
+
+
+setup(
+ name=name,
+ version=version,
+ description='Python bindings for GlusterFS libgfapi',
+ license='Apache License (2.0)',
+ author='Red Hat, Inc.',
+ author_email='gluster-users@gluster.org',
+ url='http://www.gluster.org',
+ packages=find_packages(exclude=['test']),
+ test_suite='nose.collector',
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable'
+ 'Environment :: OpenStack'
+ 'Intended Audience :: Information Technology'
+ 'Intended Audience :: System Administrators'
+ 'License :: OSI Approved :: Apache Software License'
+ 'Operating System :: POSIX :: Linux'
+ 'Programming Language :: Python'
+ 'Programming Language :: Python :: 2'
+ 'Programming Language :: Python :: 2.6'
+ 'Programming Language :: Python :: 2.7'
+ ],
+ install_requires=[],
+ scripts=[],
+ entry_points={},
+)