summaryrefslogtreecommitdiffstats
path: root/glustolibs-io/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'glustolibs-io/setup.py')
-rw-r--r--glustolibs-io/setup.py34
1 files changed, 20 insertions, 14 deletions
diff --git a/glustolibs-io/setup.py b/glustolibs-io/setup.py
index 41655dad6..4e3b16e89 100644
--- a/glustolibs-io/setup.py
+++ b/glustolibs-io/setup.py
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python
# Copyright (c) 2016 Red Hat, Inc.
#
# This program is free software; you can redistribute it and/or modify
@@ -15,9 +15,11 @@
# with this program; if not, write to the Free Software Foundation, Inc.,
# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
#
+
+from distutils import dir_util
import os
+
from setuptools import setup, find_packages
-from distutils import dir_util
version = '0.1.2'
name = 'glustolibs-io'
@@ -32,23 +34,27 @@ setup(
url='http://www.gluster.org',
packages=find_packages(),
classifiers=[
- 'Development Status :: 4 - Beta'
- 'Environment :: Console'
- 'Intended Audience :: Developers'
- 'License :: OSI Approved :: GNU General Public License v2 or later (GPLv2+)'
- 'Operating System :: POSIX :: Linux'
- 'Programming Language :: Python'
- 'Programming Language :: Python :: 2'
- 'Programming Language :: Python :: 2.6'
- 'Programming Language :: Python :: 2.7'
- 'Topic :: Software Development :: Testing'
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: GNU General Public License v2 or '
+ 'later (GPLv2+)',
+ 'Operating System :: POSIX :: Linux',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Topic :: Software Development :: Testing',
],
install_requires=['glusto'],
- dependency_links=['http://github.com/loadtheaccumulator/glusto/tarball/master#egg=glusto'],
+ dependency_links=[
+ 'http://github.com/loadtheaccumulator/glusto/tarball/master#egg=glusto'
+ ],
namespace_packages = ['glustolibs']
)
try:
dir_util.copy_tree('./shared_files', '/usr/share/glustolibs/io')
-except:
+except Exception:
pass