summaryrefslogtreecommitdiffstats
path: root/tools/log_splitter/setup.py
diff options
context:
space:
mode:
authorkshithijiyer <kshithij.ki@gmail.com>2020-07-10 18:21:36 +0530
committerBala Konda Reddy M <bala12352@gmail.com>2020-07-15 10:04:10 +0000
commit2b2bd0ab3fe94bd835a997f8b2bdabe1c66c42b9 (patch)
treec478b232882049c1ba7162f2296c0a134249ea90 /tools/log_splitter/setup.py
parenta9532ef6f4ddeeeae27d12eb3d5fd122dad2b4d7 (diff)
[Tool] Add tool to split log to tc wise logs
Adding tool to split glusto-tests logs into tc wise logs. usage: log_splitter [-h] -f LOG_FILE [-d DESTINATION_DIR] Tool to split glusto logs to individual testcase logs. optional arguments: -h, --help show this help message and exit -f LOG_FILE, --log_file LOG_FILE Glusto test log file -d DESTINATION_DIR, --dist-dir DESTINATION_DIR Path were individual test logs are to be stored. Change-Id: I776a1455f9f70c13ae6ad9d11f23a4b5366c5f6f Signed-off-by: kshithijiyer <kshithij.ki@gmail.com>
Diffstat (limited to 'tools/log_splitter/setup.py')
-rw-r--r--tools/log_splitter/setup.py33
1 files changed, 33 insertions, 0 deletions
diff --git a/tools/log_splitter/setup.py b/tools/log_splitter/setup.py
new file mode 100644
index 000000000..2d922f30a
--- /dev/null
+++ b/tools/log_splitter/setup.py
@@ -0,0 +1,33 @@
+# Copyright (C) 2020 Red Hat, Inc. <http://www.redhat.com>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY :or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+from setuptools import setup
+
+setup(
+ name='log_splitter',
+ version="1.0",
+ author='Red Hat, Inc.',
+ author_email='gluster-devel@gluster.org',
+ url='http://www.gluster.org',
+ licens="GPLv3+",
+ description=("Tool to split glusto logs to "
+ "individual testcase logs."),
+ py_modules=['log_splitter'],
+ entry_points="""
+ [console_scripts]
+ log_splitter = log_splitter:main
+ """
+)