summaryrefslogtreecommitdiffstats
path: root/xlators/storage/posix/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/storage/posix/src/Makefile.am')
-rw-r--r--xlators/storage/posix/src/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/xlators/storage/posix/src/Makefile.am b/xlators/storage/posix/src/Makefile.am
index 2245098c9e4..8ec460578b5 100644
--- a/xlators/storage/posix/src/Makefile.am
+++ b/xlators/storage/posix/src/Makefile.am
@@ -4,12 +4,13 @@ xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/storage
posix_la_LDFLAGS = -module $(GF_XLATOR_DEFAULT_LDFLAGS)
-posix_la_SOURCES = posix.c posix-helpers.c posix-handle.c posix-aio.c
+posix_la_SOURCES = posix.c posix-helpers.c posix-handle.c posix-aio.c \
+ posix-gfid-path.c
posix_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la $(LIBAIO) \
$(ACL_LIBS)
noinst_HEADERS = posix.h posix-mem-types.h posix-handle.h posix-aio.h \
- posix-messages.h
+ posix-messages.h posix-gfid-path.h
AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src \
-I$(top_srcdir)/rpc/xdr/src -I$(top_builddir)/rpc/xdr/src \