summaryrefslogtreecommitdiffstats
path: root/xlators/storage/posix/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/storage/posix/src/Makefile.am')
-rw-r--r--xlators/storage/posix/src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/xlators/storage/posix/src/Makefile.am b/xlators/storage/posix/src/Makefile.am
index 4eae9798b15..f9e7d83ecce 100644
--- a/xlators/storage/posix/src/Makefile.am
+++ b/xlators/storage/posix/src/Makefile.am
@@ -9,8 +9,8 @@ posix_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la $(LIBAIO)
noinst_HEADERS = posix.h posix-mem-types.h posix-handle.h posix-aio.h
-AM_CFLAGS = -fPIC -fno-strict-aliasing -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE \
- -D$(GF_HOST_OS) -Wall -I$(top_srcdir)/libglusterfs/src -shared \
+AM_CFLAGS = -fPIC -fno-strict-aliasing $(GF_CPPFLAGS) \
+ -Wall -I$(top_srcdir)/libglusterfs/src -shared \
-nostartfiles -I$(top_srcdir)/rpc/xdr/src \
-I$(top_srcdir)/rpc/rpc-lib/src $(GF_CFLAGS)