summaryrefslogtreecommitdiffstats
path: root/xlators/storage/bd/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/storage/bd/src/Makefile.am')
-rw-r--r--xlators/storage/bd/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/xlators/storage/bd/src/Makefile.am b/xlators/storage/bd/src/Makefile.am
index 60ceff31b20..f0fbc24086a 100644
--- a/xlators/storage/bd/src/Makefile.am
+++ b/xlators/storage/bd/src/Makefile.am
@@ -2,7 +2,7 @@ if ENABLE_BD_XLATOR
xlator_LTLIBRARIES = bd.la
xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/storage
-bd_la_LDFLAGS = -module -avoid-version
+bd_la_LDFLAGS = $(GF_XLATOR_DEFAULT_LDFLAGS)
LIBBD = -llvm2app -lrt
bd_la_SOURCES = bd.c bd-helper.c bd-aio.c
bd_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la $(LIBBD) $(LIBAIO)