summaryrefslogtreecommitdiffstats
path: root/xlators/performance/stat-prefetch/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/performance/stat-prefetch/src/Makefile.am')
-rw-r--r--xlators/performance/stat-prefetch/src/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/xlators/performance/stat-prefetch/src/Makefile.am b/xlators/performance/stat-prefetch/src/Makefile.am
new file mode 100644
index 00000000000..e52f2df48fd
--- /dev/null
+++ b/xlators/performance/stat-prefetch/src/Makefile.am
@@ -0,0 +1,11 @@
+xlator_PROGRAMS = stat-prefetch.so
+xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/performance
+
+stat_prefetch_so_SOURCES = stat-prefetch.c
+noinst_HEADERS = stat-prefetch.h
+
+AM_CFLAGS = -fPIC -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -Wall \
+ -I$(top_srcdir)/libglusterfs/src -shared -nostartfiles
+
+CLEANFILES =
+