summaryrefslogtreecommitdiffstats
path: root/xlators/mount/fuse/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/mount/fuse/src/Makefile.am')
-rw-r--r--xlators/mount/fuse/src/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/xlators/mount/fuse/src/Makefile.am b/xlators/mount/fuse/src/Makefile.am
index e85d63887dc..4374c96b533 100644
--- a/xlators/mount/fuse/src/Makefile.am
+++ b/xlators/mount/fuse/src/Makefile.am
@@ -4,13 +4,20 @@ noinst_HEADERS = $(CONTRIBDIR)/fuse-include/fuse_kernel.h\
xlator_LTLIBRARIES = fuse.la
xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/mount
+
+if GF_DARWIN_HOST_OS
+ mount_source=$(CONTRIBDIR)/macfuse/mount_darwin.c
+else
+ mount_source=$(CONTRIBDIR)/fuse-lib/mount.c
+endif
+
fuse_la_SOURCES = fuse-bridge.c $(CONTRIBDIR)/fuse-lib/misc.c \
- $(CONTRIBDIR)/fuse-lib/mount.c
+ $(mount_source)
fuse_la_LDFLAGS = -module -avoidversion -shared -nostartfiles
AM_CFLAGS = -fPIC -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D$(GF_HOST_OS) -Wall \
-I$(top_srcdir)/libglusterfs/src -I$(CONTRIBDIR)/fuse-include \
- $(GF_CFLAGS) -DFUSERMOUNT_DIR=\"$(bindir)\"
+ $(GF_CFLAGS) $(GF_FUSE_CFLAGS)
CLEANFILES =