summaryrefslogtreecommitdiffstats
path: root/xlators/features/protect/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/features/protect/src/Makefile.am')
-rw-r--r--xlators/features/protect/src/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/xlators/features/protect/src/Makefile.am b/xlators/features/protect/src/Makefile.am
index 98499712fab..58ca471141c 100644
--- a/xlators/features/protect/src/Makefile.am
+++ b/xlators/features/protect/src/Makefile.am
@@ -4,18 +4,19 @@ xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/features
prot_dht_la_LDFLAGS = -module $(GF_XLATOR_DEFAULT_LDFLAGS)
prot_dht_la_SOURCES = prot_dht.c
-prot_dht_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+prot_dht_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
prot_client_la_LDFLAGS = -module $(GF_XLATOR_DEFAULT_LDFLAGS)
prot_client_la_SOURCES = prot_client.c
-prot_client_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+prot_client_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
prot_server_la_LDFLAGS = -module $(GF_XLATOR_DEFAULT_LDFLAGS)
prot_server_la_SOURCES = prot_server.c
-prot_server_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+prot_server_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src \
- -I$(CONTRIBDIR)/libexecinfo
+ -I$(top_srcdir)/rpc/xdr/src -I$(top_builddir)/rpc/xdr/src \
+ -I$(CONTRIBDIR)/libexecinfo
AM_CFLAGS = -Wall $(GF_CFLAGS)
CLEANFILES =