summaryrefslogtreecommitdiffstats
path: root/xlators/features/glupy/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/features/glupy/src/Makefile.am')
-rw-r--r--xlators/features/glupy/src/Makefile.am15
1 files changed, 7 insertions, 8 deletions
diff --git a/xlators/features/glupy/src/Makefile.am b/xlators/features/glupy/src/Makefile.am
index b5d1c964432..25fd48ba176 100644
--- a/xlators/features/glupy/src/Makefile.am
+++ b/xlators/features/glupy/src/Makefile.am
@@ -4,24 +4,23 @@ xlator_LTLIBRARIES = glupy.la
xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/features
glupydir = $(xlatordir)/glupy
-AM_CPPFLAGS = $(PYTHONDEV_CPPFLAGS) $(GF_CPPFLAGS) \
+AM_CPPFLAGS = $(GF_CPPFLAGS) \
-I$(top_srcdir)/libglusterfs/src \
- -I$(top_srcdir)/rpc/xdr/src -I$(top_builddir)/rpc/xdr/src \
- -isystem $(BUILD_PYTHON_INC)
+ -I$(top_srcdir)/rpc/xdr/src -I$(top_builddir)/rpc/xdr/src
-AM_CFLAGS = $(PYTHONDEV_CPPFLAGS) -Wall -fno-strict-aliasing \
+AM_CFLAGS = -Wall -fno-strict-aliasing \
-DGLUSTER_PYTHON_PATH=\"$(glupydir)\" \
-DPATH_GLUSTERFS_GLUPY_MODULE=\"${xlatordir}/glupy${shrext_cmds}\" \
- $(GF_CFLAGS)
+ $(GF_CFLAGS) $(PYTHON_CFLAGS)
# Flags to build glupy.so with
-glupy_la_LDFLAGS = $(PYTHONDEV_LDFLAGS) -module -avoid-version -nostartfiles \
+glupy_la_LDFLAGS = -module -avoid-version -nostartfiles \
-export-symbols $(top_srcdir)/xlators/features/glupy/src/glupy.sym \
- $(GF_NO_UNDEFINED)
+ $(GF_NO_UNDEFINED) $(PYTHON_LIBS)
glupy_la_SOURCES = glupy.c
glupy_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la \
- -lpthread -l$(BUILD_PYTHON_LIB) $(LIB_DL)
+ -lpthread $(LIB_DL)
noinst_HEADERS = glupy.h