summaryrefslogtreecommitdiffstats
path: root/xlators/features/bit-rot/src/bitd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/features/bit-rot/src/bitd/Makefile.am')
-rw-r--r--xlators/features/bit-rot/src/bitd/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/xlators/features/bit-rot/src/bitd/Makefile.am b/xlators/features/bit-rot/src/bitd/Makefile.am
index dfa29fd72d9..2df6f68a68a 100644
--- a/xlators/features/bit-rot/src/bitd/Makefile.am
+++ b/xlators/features/bit-rot/src/bitd/Makefile.am
@@ -4,15 +4,14 @@ xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/features
bit_rot_la_LDFLAGS = -module $(GF_XLATOR_DEFAULT_LDFLAGS)
AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src \
- -I$(top_srcdir)/rpc/xdr/src/ \
- -I$(top_srcdir)/rpc/rpc-lib/src \
- -I$(CONTRIBDIR)/timer-wheel \
- -I$(top_srcdir)/xlators/features/bit-rot/src/stub
+ -I$(top_srcdir)/rpc/xdr/src/ -I$(top_builddir)/rpc/xdr/src/ \
+ -I$(top_srcdir)/rpc/rpc-lib/src -I$(CONTRIBDIR)/timer-wheel \
+ -I$(top_srcdir)/xlators/features/bit-rot/src/stub
bit_rot_la_SOURCES = bit-rot.c bit-rot-scrub.c bit-rot-ssm.c \
bit-rot-scrub-status.c
bit_rot_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la \
- $(top_builddir)/xlators/features/changelog/lib/src/libgfchangelog.la
+ $(top_builddir)/xlators/features/changelog/lib/src/libgfchangelog.la
noinst_HEADERS = bit-rot.h bit-rot-scrub.h bit-rot-bitd-messages.h bit-rot-ssm.h \
bit-rot-scrub-status.h