summaryrefslogtreecommitdiffstats
path: root/xlators/features/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/features/Makefile.am')
-rw-r--r--xlators/features/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/xlators/features/Makefile.am b/xlators/features/Makefile.am
index 81fbe856e78..6ef19af0860 100644
--- a/xlators/features/Makefile.am
+++ b/xlators/features/Makefile.am
@@ -1,6 +1,11 @@
+if BUILD_CLOUDSYNC
+ CLOUDSYNC_DIR = cloudsync
+endif
+
+
SUBDIRS = locks quota read-only quiesce marker index barrier \
arbiter compress changelog changetimerecorder \
gfid-access $(GLUPY_SUBDIR) upcall snapview-client snapview-server \
- trash shard bit-rot leases selinux sdfs namespace cloudsync thin-arbiter \
+ trash shard bit-rot leases selinux sdfs namespace $(CLOUDSYNC_DIR) thin-arbiter \
utime
CLEANFILES =