summaryrefslogtreecommitdiffstats
path: root/xlators/encryption/crypt/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xlators/encryption/crypt/src/Makefile.am')
-rw-r--r--xlators/encryption/crypt/src/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/xlators/encryption/crypt/src/Makefile.am b/xlators/encryption/crypt/src/Makefile.am
index b13f65043d3..d7ebac61884 100644
--- a/xlators/encryption/crypt/src/Makefile.am
+++ b/xlators/encryption/crypt/src/Makefile.am
@@ -3,10 +3,10 @@ if ENABLE_CRYPT_XLATOR
xlator_LTLIBRARIES = crypt.la
xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/encryption
-crypt_la_LDFLAGS = -module -avoid-version -lssl -lcrypto
+crypt_la_LDFLAGS = -module -avoid-version
crypt_la_SOURCES = keys.c data.c metadata.c atom.c crypt.c
-crypt_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+crypt_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la -lssl -lcrypto
noinst_HEADERS = crypt-common.h crypt-mem-types.h crypt.h metadata.h
@@ -21,4 +21,4 @@ else
noinst_DIST = keys.c data.c metadata.c atom.c crypt.c
noinst_HEADERS = crypt-common.h crypt-mem-types.h crypt.h metadata.h
-endif \ No newline at end of file
+endif