summaryrefslogtreecommitdiffstats
path: root/transport/ib-verbs/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'transport/ib-verbs/src/Makefile.am')
-rw-r--r--transport/ib-verbs/src/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/transport/ib-verbs/src/Makefile.am b/transport/ib-verbs/src/Makefile.am
new file mode 100644
index 00000000000..e6240090e92
--- /dev/null
+++ b/transport/ib-verbs/src/Makefile.am
@@ -0,0 +1,15 @@
+noinst_HEADERS = ib-verbs.h name.h
+
+transport_LTLIBRARIES = ib-verbs.la
+transportdir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/transport/
+
+ib_verbs_la_LDFLAGS = -module -avoidversion
+
+ib_verbs_la_SOURCES = ib-verbs.c name.c
+ib_verbs_la_LIBADD = -libverbs $(top_builddir)/libglusterfs/src/libglusterfs.la
+
+AM_CFLAGS = -fPIC -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -Wall -D$(GF_HOST_OS)\
+ -I$(top_srcdir)/libglusterfs/src -I$(top_srcdir)/transport/ib-verbs \
+ -shared -nostartfiles
+
+CLEANFILES = *~