summaryrefslogtreecommitdiffstats
path: root/rpc/xdr/gen/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'rpc/xdr/gen/Makefile.am')
-rw-r--r--rpc/xdr/gen/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/rpc/xdr/gen/Makefile.am b/rpc/xdr/gen/Makefile.am
index c253e38275d..df379b80130 100644
--- a/rpc/xdr/gen/Makefile.am
+++ b/rpc/xdr/gen/Makefile.am
@@ -18,14 +18,14 @@ xdrdst=$(top_builddir)/rpc/xdr/src
# could use a '-' (i.e. -@rpcgen ...) and suffer with noisy warnings
# in the build. Or we do this crufty thing instead.
$(XDRSOURCES): $(XDRGENFILES)
- if [ ! -e $(xdrdst)/$@ -o $(@:.c=.x) -nt $(xdrdst)/$@ ]; then \
+ @if [ ! -e $(xdrdst)/$@ -o $(@:.c=.x) -nt $(xdrdst)/$@ ]; then \
rpcgen -c -o $(xdrdst)/$@ $(@:.c=.x) ;\
fi
# d*mn sed in netbsd6 doesn't do -i (inline)
# (why are we still running smoke on netbsd6 and not netbsd7?)
$(XDRHEADERS): $(XDRGENFILES)
- if [ ! -e $(xdrdst)/$@ -o $(@:.h=.x) -nt $(xdrdst)/$@ ]; then \
+ @if [ ! -e $(xdrdst)/$@ -o $(@:.h=.x) -nt $(xdrdst)/$@ ]; then \
rpcgen -h -o $(@:.h=.tmp) $(@:.h=.x) && \
sed -e '/#ifndef/ s/-/_/g' -e '/#define/ s/-/_/g' \
-e '/#endif/ s/-/_/' -e 's/TMP_/H_/g' \