summaryrefslogtreecommitdiffstats
path: root/rpc/xdr/gen/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'rpc/xdr/gen/Makefile.am')
-rw-r--r--rpc/xdr/gen/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/rpc/xdr/gen/Makefile.am b/rpc/xdr/gen/Makefile.am
index d6f416f93b7..6cffca4c3ac 100644
--- a/rpc/xdr/gen/Makefile.am
+++ b/rpc/xdr/gen/Makefile.am
@@ -10,6 +10,7 @@ CLEANFILES = $(XDRSOURCES) $(XDRHEADERS)
BUILT_SOURCES = $(XDRHEADERS) $(XDRSOURCES)
xdrsrc=$(top_srcdir)/rpc/xdr/src
+xdrdst=$(top_builddir)/rpc/xdr/src
# make's dependency resolution may mean that it decides to run
# rpcgen again (unnecessarily), but as the .c file already exists,
@@ -17,19 +18,19 @@ xdrsrc=$(top_srcdir)/rpc/xdr/src
# could use a '-' (i.e. -@rpcgen ...) and suffer with noisy warnings
# in the build. Or we do this crufty thing instead.
$(XDRSOURCES): $(XDRGENFILES)
- if [ ! -e $@ -o $(@:.c=.x) -nt $@ ]; then \
- rpcgen -c -o $@ $(@:.c=.x) && cp $@ $(xdrsrc)/ ;\
+ if [ ! -e $(xdrdst)/$@ -o $(@:.c=.x) -nt $(xdrdst)/$@ ]; then \
+ rpcgen -c -o $(xdrdst)/$@ $(@:.c=.x) ;\
fi
# d*mn sed in netbsd6 doesn't do -i (inline)
# (why are we still running smoke on netbsd6 and not netbsd7?)
$(XDRHEADERS): $(XDRGENFILES)
- if [ ! -e $@ -o $(@:.h=.x) -nt $@ ]; then \
+ if [ ! -e $(xdrdst)/$@ -o $(@:.h=.x) -nt $(xdrdst)/$@ ]; then \
rpcgen -h -o $(@:.h=.tmp) $(@:.h=.x) && \
sed -e '/#ifndef/ s/-/_/g' -e '/#define/ s/-/_/g' \
-e '/#endif/ s/-/_/' -e 's/TMP_/H_/g' \
- $(@:.h=.tmp) > $@ && rm -f $(@:.h=.tmp) && \
- cp $@ $(xdrsrc)/ ; \
+ $(@:.h=.tmp) > $(xdrdst)/$@ && \
+ rm -f $(@:.h=.tmp) ; \
fi