summaryrefslogtreecommitdiffstats
path: root/extras/ocf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'extras/ocf/Makefile.am')
-rw-r--r--extras/ocf/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/extras/ocf/Makefile.am b/extras/ocf/Makefile.am
new file mode 100644
index 00000000000..2d7410099e0
--- /dev/null
+++ b/extras/ocf/Makefile.am
@@ -0,0 +1,13 @@
+EXTRA_DIST = glusterd.in volume.in
+
+if WITH_OCF
+# The root of the OCF resource agent hierarchy
+# Per the OCF standard, it's always "lib",
+# not "lib64" (even on 64-bit platforms).
+ocfdir = $(prefix)/lib/ocf
+
+# The ceph provider directory
+radir = $(ocfdir)/resource.d/$(PACKAGE_NAME)
+
+ra_SCRIPTS = glusterd volume
+endif