summaryrefslogtreecommitdiffstats
path: root/extras/init.d/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'extras/init.d/Makefile.am')
-rw-r--r--extras/init.d/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/extras/init.d/Makefile.am b/extras/init.d/Makefile.am
index 6f479e7ca5b..c090161780b 100644
--- a/extras/init.d/Makefile.am
+++ b/extras/init.d/Makefile.am
@@ -4,6 +4,7 @@ EXTRA_DIST = glusterfsd-Debian glusterfsd-Redhat glusterfsd-SuSE glusterfs-serve
CLEANFILES =
initdir = @initdir@
+launchddir = @launchddir@
$(GF_DISTRIBUTION):
$(mkdir_p) $(DESTDIR)$(initdir)
@@ -13,5 +14,6 @@ install-exec-local: $(GF_DISTRIBUTION)
install-data-local:
if GF_DARWIN_HOST_OS
- cp glusterfs-server.plist /Library/LaunchDaemons/com.gluster.glusterfs.plist
+ $(mkdir_p) $(DESTDIR)$(launchddir)
+ $(INSTALL_PROGRAM) glusterfs-server.plist $(DESTDIR)$(launchddir)/com.gluster.glusterfs.plist
endif