summaryrefslogtreecommitdiffstats
path: root/contrib/ipaddr-py/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/ipaddr-py/setup.py')
-rwxr-xr-xcontrib/ipaddr-py/setup.py36
1 files changed, 36 insertions, 0 deletions
diff --git a/contrib/ipaddr-py/setup.py b/contrib/ipaddr-py/setup.py
new file mode 100755
index 00000000000..33564320e45
--- /dev/null
+++ b/contrib/ipaddr-py/setup.py
@@ -0,0 +1,36 @@
+#!/usr/bin/python
+#
+# Copyright 2008 Google Inc.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+from distutils.core import setup
+
+import ipaddr
+
+
+setup(name='ipaddr',
+ maintainer='Google',
+ maintainer_email='ipaddr-py-dev@googlegroups.com',
+ version=ipaddr.__version__,
+ url='http://code.google.com/p/ipaddr-py/',
+ license='Apache License, Version 2.0',
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Operating System :: OS Independent',
+ 'Topic :: Internet',
+ 'Topic :: Software Development :: Libraries',
+ 'Topic :: System :: Networking'],
+ py_modules=['ipaddr'])