summaryrefslogtreecommitdiffstats
path: root/contrib/fuse-util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/fuse-util/Makefile.am')
-rw-r--r--contrib/fuse-util/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/contrib/fuse-util/Makefile.am b/contrib/fuse-util/Makefile.am
new file mode 100644
index 00000000000..06b6cb6da72
--- /dev/null
+++ b/contrib/fuse-util/Makefile.am
@@ -0,0 +1,12 @@
+bin_PROGRAMS = fusermount-glusterfs
+
+fusermount_glusterfs_SOURCES = fusermount.c $(CONTRIBDIR)/fuse-lib/mount.c
+noinst_HEADERS = mount_util.h
+
+AM_CFLAGS = -Wall -D_FILE_OFFSET_BITS=64 -DFUSE_UTIL $(GF_CFLAGS)
+
+install-exec-hook:
+ chown root $(DESTDIR)$(bindir)/fusermount-glusterfs
+ chmod u+s $(DESTDIR)$(bindir)/fusermount-glusterfs
+
+CLEANFILES =