summaryrefslogtreecommitdiffstats
path: root/cli/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cli/src/Makefile.am')
-rw-r--r--cli/src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/cli/src/Makefile.am b/cli/src/Makefile.am
index ee6a675edba..084cad5d97c 100644
--- a/cli/src/Makefile.am
+++ b/cli/src/Makefile.am
@@ -5,7 +5,7 @@ gluster_SOURCES = cli.c registry.c input.c cli-cmd.c cli-rl.c \
cli-cmd-misc.c
gluster_LDADD = $(top_builddir)/libglusterfs/src/libglusterfs.la $(GF_LDADD)\
- $(RLLIBS) $(top_builddir)/xlators/protocol/lib/src/libgfproto1.la\
+ $(RLLIBS) $(top_builddir)/rpc/xdr/src/libgfxdr.la
$(top_builddir)/rpc/rpc-lib/src/libgfrpc.la
gluster_LDFLAGS = $(GF_LDFLAGS) $(GF_GLUSTERFS_LDFLAGS)
@@ -13,7 +13,7 @@ noinst_HEADERS = cli.h cli-mem-types.h cli-cmd.h
AM_CFLAGS = -fPIC -Wall -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D$(GF_HOST_OS)\
-I$(top_srcdir)/libglusterfs/src -I$(top_srcdir)/rpc/rpc-lib/src\
- -I$(top_srcdir)/xlators/protocol/lib/src\
+ -I$(top_srcdir)/rpc/xdr/src\
-DDATADIR=\"$(localstatedir)\" \
-DCONFDIR=\"$(sysconfdir)/glusterfs\" $(GF_GLUSTERFS_CFLAGS)