summaryrefslogtreecommitdiffstats
path: root/xlators/system/posix-acl/src/Makefile.am
diff options
context:
space:
mode:
authorJeff Darcy <jdarcy@redhat.com>2012-10-03 09:45:22 -0400
committerAnand Avati <avati@redhat.com>2012-10-03 12:25:34 -0700
commitb026c96a61a65393ab0469aa1d9187b1c258e3a7 (patch)
treedc684cc265d9546e424dbc6f79c85839e3169a52 /xlators/system/posix-acl/src/Makefile.am
parent1ecbb7ca68bd39ede792414b21a772469ecb4094 (diff)
build: move -L arguments out of CFLAGS
"-L" is a linker flag, and as such should be in LDFLAGS, not CFLAGS, to have guaranteed effect. Change-Id: I014db3f48823d4923b45e0695b62b124eb1a1506 BUG: 862082 Original-author: Jan Engelhardt <jengelh@inai.de> Signed-off-by: Jan Engelhardt <jengelh@inai.de> Signed-off-by: Jeff Darcy <jdarcy@redhat.com> Reviewed-on: http://review.gluster.org/4028 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Anand Avati <avati@redhat.com>
Diffstat (limited to 'xlators/system/posix-acl/src/Makefile.am')
-rw-r--r--xlators/system/posix-acl/src/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/xlators/system/posix-acl/src/Makefile.am b/xlators/system/posix-acl/src/Makefile.am
index 6659b9d9c5a..200717f2678 100644
--- a/xlators/system/posix-acl/src/Makefile.am
+++ b/xlators/system/posix-acl/src/Makefile.am
@@ -7,8 +7,9 @@ posix_acl_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
noinst_HEADERS = posix-acl.h posix-acl-xattr.h
AM_CFLAGS = $(GF_CPPFLAGS) -Wall \
- -I$(top_srcdir)/libglusterfs/src $(GF_CFLAGS)\
- -L$(xlatordir)/
+ -I$(top_srcdir)/libglusterfs/src $(GF_CFLAGS)
+
+AM_LDFLAGS = -L$(xlatordir)
CLEANFILES =