summaryrefslogtreecommitdiffstats
path: root/xlators/protocol/server/src/Makefile.am
diff options
context:
space:
mode:
authorJeff Darcy <jdarcy@redhat.com>2012-10-03 09:48:45 -0400
committerAnand Avati <avati@redhat.com>2012-10-03 12:26:45 -0700
commit58e6296fa2b59506cacab32689df77a211e578cb (patch)
treef851b0d08e2ca9303a3faf62c351964b5804840a /xlators/protocol/server/src/Makefile.am
parentb026c96a61a65393ab0469aa1d9187b1c258e3a7 (diff)
build: split CPPFLAGS from CFLAGS
Automake provides a separate variable for preprocessor flags (*_CPPFLAGS). They are already uses in a few places, so make it consistent and use it everywhere. Note that cflags obtained from pkg-config often are cppflags, which is why LIBXML2_CFLAGS moves with into AM_CPPFLAGS, for example. Change-Id: I15feed1d18b2ca497371271c4b5876d5ec6289dd BUG: 862082 Original-author: Jan Engelhardt <jengelh@inai.de> Signed-off-by: Jan Engelhardt <jengelh@inai.de> Signed-off-by: Jeff Darcy <jdarcy@redhat.com> Reviewed-on: http://review.gluster.org/4029 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Anand Avati <avati@redhat.com>
Diffstat (limited to 'xlators/protocol/server/src/Makefile.am')
-rw-r--r--xlators/protocol/server/src/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/xlators/protocol/server/src/Makefile.am b/xlators/protocol/server/src/Makefile.am
index 2e94dcb8788..c7ac3817211 100644
--- a/xlators/protocol/server/src/Makefile.am
+++ b/xlators/protocol/server/src/Makefile.am
@@ -12,12 +12,14 @@ server_la_SOURCES = server.c server-resolve.c server-helpers.c \
noinst_HEADERS = server.h server-helpers.h server-mem-types.h authenticate.h
-AM_CFLAGS = $(GF_CPPFLAGS) -Wall \
+AM_CPPFLAGS = $(GF_CPPFLAGS) \
-I$(top_srcdir)/libglusterfs/src \
-DCONFDIR=\"$(sysconfdir)/glusterfs\" \
-DLIBDIR=\"$(libdir)/glusterfs/$(PACKAGE_VERSION)/auth\" \
- $(GF_CFLAGS) -I$(top_srcdir)/xlators/protocol/lib/src \
+ -I$(top_srcdir)/xlators/protocol/lib/src \
-I$(top_srcdir)/rpc/rpc-lib/src/ \
-I$(top_srcdir)/rpc/xdr/src/
+AM_CFLAGS = -Wall $(GF_CFLAGS)
+
CLEANFILES = *~