summaryrefslogtreecommitdiffstats
path: root/xlators/protocol/auth/login/src/Makefile.am
diff options
context:
space:
mode:
authorAmar Tumballi <amar@gluster.com>2010-05-04 00:36:24 +0000
committerAnand V. Avati <avati@dev.gluster.com>2010-05-03 23:40:05 -0700
commitf75b76350747f5f58a4bbe704915c74979cc5ac3 (patch)
treeaf828761f51a8aa2612aa5eb9c9f0709869675c8 /xlators/protocol/auth/login/src/Makefile.am
parent7504b0e623914d097933f0a613ba50e376131828 (diff)
structuring of protocol - 2
* 'transports/' and 'auth/' moved to xlators/protocol/ * transport.{c,h}, authenticate.{c,h}, protocol.h moved to xlators/protocol/lib/src/ Signed-off-by: Amar Tumballi <amar@gluster.com> Signed-off-by: Anand V. Avati <avati@dev.gluster.com> BUG: 875 (Implement a new protocol to provide proper backward/forward compatibility) URL: http://bugs.gluster.com/cgi-bin/bugzilla3/show_bug.cgi?id=875
Diffstat (limited to 'xlators/protocol/auth/login/src/Makefile.am')
-rw-r--r--xlators/protocol/auth/login/src/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/xlators/protocol/auth/login/src/Makefile.am b/xlators/protocol/auth/login/src/Makefile.am
new file mode 100644
index 00000000000..4a50e07d309
--- /dev/null
+++ b/xlators/protocol/auth/login/src/Makefile.am
@@ -0,0 +1,15 @@
+auth_LTLIBRARIES = login.la
+authdir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/auth
+
+login_la_LDFLAGS = -module -avoidversion
+
+login_la_SOURCES = login.c
+login_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la \
+ $(top_builddir)/xlators/protocol/lib/src/libgfproto.la
+
+
+AM_CFLAGS = -fPIC -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -Wall -D$(GF_HOST_OS)\
+ -I$(top_srcdir)/libglusterfs/src -shared -nostartfiles $(GF_CFLAGS) \
+ -I$(top_srcdir)/xlators/protocol/lib/src
+
+CLEANFILES =