summaryrefslogtreecommitdiffstats
path: root/xlators/playground/template/src/Makefile.am
diff options
context:
space:
mode:
authorKrishnan Parthasarathi <kparthas@redhat.com>2013-03-01 16:18:26 +0530
committerVijay Bellur <vbellur@redhat.com>2013-06-05 05:32:21 -0700
commit31f58221811cf901f02059a4751b20483d26d79d (patch)
treef4d9d32a138aa5049bdf5fa9fc0fbdda0b1dc82e /xlators/playground/template/src/Makefile.am
parent68a97ece53ec1da205a4da6da5d9d7f8b58b3f5e (diff)
template: A minimal example xlator to build on
This xlator is intended to save new GlusterFS developers from fighting it with autotools. How to add template xl onto the xlator graph? [..] volname-template type testing/features/template subvolumes volname-dht end-volume [..] Change-Id: If513284bb590be7c3b093054108dba2883064190 BUG: 916985 Signed-off-by: Krishnan Parthasarathi <kparthas@redhat.com> Reviewed-on: http://review.gluster.org/4604 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Diffstat (limited to 'xlators/playground/template/src/Makefile.am')
-rw-r--r--xlators/playground/template/src/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/xlators/playground/template/src/Makefile.am b/xlators/playground/template/src/Makefile.am
new file mode 100644
index 00000000000..21f1c5f6b75
--- /dev/null
+++ b/xlators/playground/template/src/Makefile.am
@@ -0,0 +1,16 @@
+xlator_LTLIBRARIES = template.la
+xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/testing/features
+
+template_la_LDFLAGS = -module -avoid-version
+
+template_la_SOURCES = template.c
+template_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+
+noinst_HEADERS = template.h
+
+AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src
+
+AM_CFLAGS = -Wall $(GF_CFLAGS)
+
+CLEANFILES =
+