summaryrefslogtreecommitdiffstats
path: root/xlators/mgmt/glusterd/src/Makefile.am
diff options
context:
space:
mode:
authorJeff Darcy <jdarcy@redhat.com>2012-10-02 10:42:01 -0400
committerAnand Avati <avati@redhat.com>2012-10-02 09:40:29 -0700
commit7d347b2b0fc1c6d5262e42bf6f89e61a1fc18204 (patch)
tree36d3c742e63d1d4dd1b41c438005c0502ad64762 /xlators/mgmt/glusterd/src/Makefile.am
parent33699838151670aac03f7f21b582419fd7611526 (diff)
build: replace INCLUDES by CPPFLAGS
automake warns: "INCLUDES" is the old name for "AM_CPPFLAGS" (or "*_CPPFLAGS") So abolish INCLUDES, and place the flags into GF_CPPFLAGS which then needs to be mentioned for glusterd. Change-Id: I326f890a69724d8b7163ce726f70ca4618c53958 BUG: 862082 Original-author: Jan Engelhardt <jengelh@inai.de> Signed-off-by: Jan Engelhardt <jengelh@inai.de> Signed-off-by: Jeff Darcy <jdarcy@redhat.com> Reviewed-on: http://review.gluster.org/4016 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Anand Avati <avati@redhat.com>
Diffstat (limited to 'xlators/mgmt/glusterd/src/Makefile.am')
-rw-r--r--xlators/mgmt/glusterd/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/xlators/mgmt/glusterd/src/Makefile.am b/xlators/mgmt/glusterd/src/Makefile.am
index 533da2a2aea..c08b7d7e823 100644
--- a/xlators/mgmt/glusterd/src/Makefile.am
+++ b/xlators/mgmt/glusterd/src/Makefile.am
@@ -1,6 +1,6 @@
xlator_LTLIBRARIES = glusterd.la
xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/mgmt
-glusterd_la_CPPFLAGS = "-DFILTERDIR=\"$(libdir)/glusterfs/$(PACKAGE_VERSION)/filter\""
+glusterd_la_CPPFLAGS = $(GF_CPPFLAGS) "-DFILTERDIR=\"$(libdir)/glusterfs/$(PACKAGE_VERSION)/filter\""
glusterd_la_LDFLAGS = -module -avoidversion $(LIBXML2_LIBS) -lcrypto
glusterd_la_SOURCES = glusterd.c glusterd-handler.c glusterd-sm.c \
glusterd-op-sm.c glusterd-utils.c glusterd-rpc-ops.c \