summaryrefslogtreecommitdiffstats
path: root/xlators/mgmt/glusterd/src/Makefile.am
diff options
context:
space:
mode:
authorVenky Shankar <vshankar@redhat.com>2015-01-07 11:14:31 +0530
committerVijay Bellur <vbellur@redhat.com>2015-03-24 07:56:32 -0700
commit84db9f8271f150fbb6024186f7f681e941731280 (patch)
treec9a3fe9dceeac5f00714362af4c7f6c706b539b2 /xlators/mgmt/glusterd/src/Makefile.am
parenta37f3ca2b286732fff18f0b0897d8bb1713c89b7 (diff)
mgmt/glusterd: generate volfile for BitD
* Implement the skeleton of bit-rot xlator. Original-Author: Raghavendra Bhat <raghavendra@redhat.com> Signed-off-by: Venky Shankar <vshankar@redhat.com> Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com> Signed-off-by: Anand Nekkunti <anekkunt@redhat.com> Change-Id: If33218bdc694f5f09cb7b8097c4fdb74d7a23b2d BUG: 1170075 Reviewed-on: http://review.gluster.org/9710 Reviewed-by: Vijay Bellur <vbellur@redhat.com> Tested-by: Vijay Bellur <vbellur@redhat.com>
Diffstat (limited to 'xlators/mgmt/glusterd/src/Makefile.am')
-rw-r--r--xlators/mgmt/glusterd/src/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/xlators/mgmt/glusterd/src/Makefile.am b/xlators/mgmt/glusterd/src/Makefile.am
index 7792f12bae9..90afa4f298b 100644
--- a/xlators/mgmt/glusterd/src/Makefile.am
+++ b/xlators/mgmt/glusterd/src/Makefile.am
@@ -15,7 +15,8 @@ glusterd_la_SOURCES = glusterd.c glusterd-handler.c glusterd-sm.c \
glusterd-snapshot-utils.c glusterd-conn-mgmt.c \
glusterd-proc-mgmt.c glusterd-svc-mgmt.c glusterd-shd-svc.c \
glusterd-nfs-svc.c glusterd-quotad-svc.c glusterd-svc-helper.c \
- glusterd-conn-helper.c glusterd-snapd-svc.c glusterd-snapd-svc-helper.c
+ glusterd-conn-helper.c glusterd-snapd-svc.c glusterd-snapd-svc-helper.c \
+ glusterd-bitd-svc.c
glusterd_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la \
@@ -35,7 +36,7 @@ noinst_HEADERS = glusterd.h glusterd-utils.h glusterd-op-sm.h \
glusterd-conn-mgmt.h glusterd-conn-helper.h glusterd-proc-mgmt.h \
glusterd-svc-mgmt.h glusterd-shd-svc.h glusterd-nfs-svc.h \
glusterd-quotad-svc.h glusterd-svc-helper.h glusterd-snapd-svc.h \
- glusterd-snapd-svc-helper.h glusterd-rcu.h \
+ glusterd-snapd-svc-helper.h glusterd-rcu.h glusterd-bitd-svc.h \
$(CONTRIBDIR)/userspace-rcu/rculist-extra.h
AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src \