summaryrefslogtreecommitdiffstats
path: root/xlators/features/upcall/Makefile.am
diff options
context:
space:
mode:
authorSoumya Koduri <skoduri@redhat.com>2015-02-15 23:35:56 +0530
committerKaleb KEITHLEY <kkeithle@redhat.com>2015-03-17 05:08:07 -0700
commit2b97b57cd8c71cb07b7002cf3483e9cfc9403c58 (patch)
tree9fc96451b469e213348f3065ca07e7a7c5a96ec0 /xlators/features/upcall/Makefile.am
parent79009691c01f2b32b523d91a159aadd0e414f31b (diff)
Upcall: New xlator to store various states and send cbk events
Framework on the server-side, to handle certain state of the files accessed and send notifications to the clients connected. A generic and extensible framework, used to maintain states in the glusterfsd process for each of the files accessed (including the clients info doing the fops) and send notifications to the respective glusterfs clients incase of any change in that state. This patch handles "Inode Update/Invalidation" upcall event. Feature page: URL: http://www.gluster.org/community/documentation/index.php/Features/Upcall-infrastructure Below link has a writeup which explains the code changes done - URL: https://soumyakoduri.wordpress.com/2015/02/25/glusterfs-understanding-upcall-infrastructure-and-cache-invalidation-support/ Change-Id: Ie3d724be9a3419fcf18901a753e8ec2df2ac802f BUG: 1200262 Signed-off-by: Soumya Koduri <skoduri@redhat.com> Reviewed-on: http://review.gluster.org/9535 Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com> Tested-by: Gluster Build System <jenkins@build.gluster.com>
Diffstat (limited to 'xlators/features/upcall/Makefile.am')
-rw-r--r--xlators/features/upcall/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/xlators/features/upcall/Makefile.am b/xlators/features/upcall/Makefile.am
new file mode 100644
index 00000000000..a985f42a877
--- /dev/null
+++ b/xlators/features/upcall/Makefile.am
@@ -0,0 +1,3 @@
+SUBDIRS = src
+
+CLEANFILES =