summaryrefslogtreecommitdiffstats
path: root/xlators/features/shard/Makefile.am
diff options
context:
space:
mode:
authorKrutika Dhananjay <kdhananj@redhat.com>2014-11-21 11:47:23 +0530
committerVijay Bellur <vbellur@redhat.com>2015-03-19 10:59:31 -0700
commit6f389fbb812b384bdd9bf4a20e86930505531996 (patch)
tree7304eeab269d1a0226274cf439fb4f6c49bfcec9 /xlators/features/shard/Makefile.am
parent32ed7aa5ad7049a9d85c795f997336c0366151a8 (diff)
features/shard: Introducing sharding translator
Based on the high-level design by Anand V. Avati which can be found @ https://gist.github.com/avati/af04f1030dcf52e16535#sharding-xlator-stripe-20 Still to-do: * complete implementation of inode write fops - [f]truncate, zerofill, fallocate, discard * introduce transaction mechanism in inode write fops * complete readv * Handle open with O_TRUNC * Handle unlinking of all shards during unlink/rename * Compute total ia_size and ia_blocks in lookup, readdirp, etc * wind fsync/flush on all shards Note: Most of the items above are related. Once we come up with a clean way to determine the last shard/shard count for a file/file size and the mgmt of sparse regions of the file, implementing them becomes trivial. Change-Id: Id871379b53a4a916e4baa2e06f197dd8c0043b0f BUG: 1200082 Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com> Reviewed-on: http://review.gluster.org/9841 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Diffstat (limited to 'xlators/features/shard/Makefile.am')
-rw-r--r--xlators/features/shard/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/xlators/features/shard/Makefile.am b/xlators/features/shard/Makefile.am
new file mode 100644
index 00000000000..a985f42a877
--- /dev/null
+++ b/xlators/features/shard/Makefile.am
@@ -0,0 +1,3 @@
+SUBDIRS = src
+
+CLEANFILES =