summaryrefslogtreecommitdiffstats
path: root/xlators/features/read-only/src/Makefile.am
diff options
context:
space:
mode:
authorshishir <shishirng@gluster.com>2011-07-19 16:02:12 +0530
committerAnand Avati <avati@gluster.com>2011-08-10 22:51:56 -0700
commit86999525240983dcbd3fe66eb40a0947730c695c (patch)
tree47ca5e1e42634de69280525f7032848cdcf6661f /xlators/features/read-only/src/Makefile.am
parent5ce1b5c357d490f68ae89bfd3ce31326a81a1183 (diff)
WORM: Write Once Read Many times xlator support
This xlator will allow files to be opened for write in append mode only. Mount with --worm(glusterfs) or -o worm (mount) option to enable worm xlator Change-Id: I1be02fcf2aee2182ea2c66b514357918136fabeb BUG: 3166 Reviewed-on: http://review.gluster.com/23 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Anand Avati <avati@gluster.com>
Diffstat (limited to 'xlators/features/read-only/src/Makefile.am')
-rw-r--r--xlators/features/read-only/src/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/xlators/features/read-only/src/Makefile.am b/xlators/features/read-only/src/Makefile.am
index 15f49966ff7..588d00cf48b 100644
--- a/xlators/features/read-only/src/Makefile.am
+++ b/xlators/features/read-only/src/Makefile.am
@@ -1,11 +1,19 @@
-xlator_LTLIBRARIES = read-only.la
+xlator_LTLIBRARIES = read-only.la worm.la
+
xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/features
+noinst_HEADERS = read-only-common.h
+
read_only_la_LDFLAGS = -module -avoidversion
read_only_la_SOURCES = read-only.c
read_only_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+worm_la_LDFLAGS = -module -avoidversion
+
+worm_la_SOURCES = read-only-common.c worm.c
+worm_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+
AM_CFLAGS = -fPIC -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -Wall -D$(GF_HOST_OS) \
-I$(top_srcdir)/libglusterfs/src -shared -nostartfiles $(GF_CFLAGS)