summaryrefslogtreecommitdiffstats
path: root/xlators/features/quiesce/src/Makefile.am
diff options
context:
space:
mode:
authorAmar Tumballi <amar@gluster.com>2010-09-28 06:11:07 +0000
committerVijay Bellur <vijay@dev.gluster.com>2010-09-29 06:17:42 -0700
commit9406c06522f9e8ef8ee73f6da55937cb1fa04d22 (patch)
tree97e30c3ba65fe11ecf45b9a88fb8ab1b9f3afc58 /xlators/features/quiesce/src/Makefile.am
parent3702814c02c0789d8b65b4f096cd0d37947eef3f (diff)
features/quiesce: new translator
'Quiesce' is used to describe pausing or altering the state of running processes on a computer In GlusterFS context, this translator looks for CHILD_DOWN/CHILD_UP events, and will hold the requests for some time if the child node is in disconnected state current timeout is 20seconds, will be made tunable soon Signed-off-by: Amar Tumballi <amar@gluster.com> Signed-off-by: Vijay Bellur <vijay@dev.gluster.com> BUG: 1500 (Mount point should not be in-accessible between reconnect to server) URL: http://bugs.gluster.com/cgi-bin/bugzilla3/show_bug.cgi?id=1500
Diffstat (limited to 'xlators/features/quiesce/src/Makefile.am')
-rw-r--r--xlators/features/quiesce/src/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/xlators/features/quiesce/src/Makefile.am b/xlators/features/quiesce/src/Makefile.am
new file mode 100644
index 00000000000..e8ab4cb2417
--- /dev/null
+++ b/xlators/features/quiesce/src/Makefile.am
@@ -0,0 +1,14 @@
+xlator_LTLIBRARIES = quiesce.la
+xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/features
+
+quiesce_la_LDFLAGS = -module -avoidversion
+
+quiesce_la_SOURCES = quiesce.c
+quiesce_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+
+noinst_HEADERS = quiesce.h quiesce-mem-types.h
+
+AM_CFLAGS = -fPIC -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -Wall -D$(GF_HOST_OS) \
+ -I$(top_srcdir)/libglusterfs/src -shared -nostartfiles $(GF_CFLAGS)
+
+CLEANFILES =