summaryrefslogtreecommitdiffstats
path: root/xlators/features/protect/src/Makefile.am
diff options
context:
space:
mode:
authorNiels de Vos <ndevos@redhat.com>2014-03-19 18:03:54 +0100
committerAnand Avati <avati@redhat.com>2014-03-21 17:28:15 -0700
commiteb87c96f49b3dd2c7460e58c54ce909c706cd475 (patch)
treeacc1947d821fdb1a1645c2aba4c5a859e25e3b57 /xlators/features/protect/src/Makefile.am
parent128863af2d7f37571583fe37424e76b46f8525d4 (diff)
build: do not create versioned <xlator>.so files
There has been a misspelled option in the Makefile.am files. The option is called -avoid-version, and not -avoidversion. It is not trivial to provide a test-case for this. One way would be to check generated RPMs with a command like this (output should be empty): $ rpm -qlp *.rpm | grep -E '/xlator/.+.so.0' Change-Id: I2a6cc557eada4d098b73af5a254f8c75707543da BUG: 1078365 Signed-off-by: Niels de Vos <ndevos@redhat.com> Reviewed-on: http://review.gluster.org/7299 Reviewed-by: Lalatendu Mohanty <lmohanty@redhat.com> Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com> Tested-by: Gluster Build System <jenkins@build.gluster.com>
Diffstat (limited to 'xlators/features/protect/src/Makefile.am')
-rw-r--r--xlators/features/protect/src/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/xlators/features/protect/src/Makefile.am b/xlators/features/protect/src/Makefile.am
index 7eb93f32e11..968e88c457a 100644
--- a/xlators/features/protect/src/Makefile.am
+++ b/xlators/features/protect/src/Makefile.am
@@ -2,15 +2,15 @@ xlator_LTLIBRARIES = prot_dht.la prot_client.la prot_server.la
xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/features
-prot_dht_la_LDFLAGS = -module -avoidversion
+prot_dht_la_LDFLAGS = -module -avoid-version
prot_dht_la_SOURCES = prot_dht.c
prot_dht_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
-prot_client_la_LDFLAGS = -module -avoidversion
+prot_client_la_LDFLAGS = -module -avoid-version
prot_client_la_SOURCES = prot_client.c
prot_client_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
-prot_server_la_LDFLAGS = -module -avoidversion
+prot_server_la_LDFLAGS = -module -avoid-version
prot_server_la_SOURCES = prot_server.c
prot_server_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la