summaryrefslogtreecommitdiffstats
path: root/xlators/features/marker/src/Makefile.am
diff options
context:
space:
mode:
authorJunaid <junaid@gluster.com>2011-01-27 05:23:31 +0000
committerAnand V. Avati <avati@dev.gluster.com>2011-01-27 03:16:57 -0800
commita2a92b99fc031544ff8a87861d34b2bbbdd2753c (patch)
treea6487aba2d552a583e514ea9e6a2714ec395b3bb /xlators/features/marker/src/Makefile.am
parent73bce15b61755509de23d32646135254d369a2f6 (diff)
adding marker translator
Signed-off-by: Junaid <junaid@gluster.com> Signed-off-by: Csaba Henk <csaba@gluster.com> Signed-off-by: Anand V. Avati <avati@dev.gluster.com> BUG: 2310 (georeplication) URL: http://bugs.gluster.com/cgi-bin/bugzilla3/show_bug.cgi?id=2310
Diffstat (limited to 'xlators/features/marker/src/Makefile.am')
-rw-r--r--xlators/features/marker/src/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/xlators/features/marker/src/Makefile.am b/xlators/features/marker/src/Makefile.am
new file mode 100644
index 00000000000..58b12b3f594
--- /dev/null
+++ b/xlators/features/marker/src/Makefile.am
@@ -0,0 +1,15 @@
+xlator_LTLIBRARIES = marker.la
+xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/features
+
+marker_la_LDFLAGS = -module -avoidversion
+
+marker_la_SOURCES = marker.c
+marker_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+
+noinst_HEADERS = marker-mem-types.h marker.h $(top_builddir)/xlators/lib/src/libxlator.h
+
+AM_CFLAGS = -fPIC -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -Wall -fno-strict-aliasing -D$(GF_HOST_OS) \
+ -I$(top_srcdir)/libglusterfs/src -I$(top_srcdir)/xlators/lib/src $(GF_CFLAGS) -shared -nostartfiles
+
+CLEANFILES =
+