summaryrefslogtreecommitdiffstats
path: root/xlators/features/gfid-access/src/Makefile.am
diff options
context:
space:
mode:
authorAmar Tumballi <amarts@redhat.com>2013-07-31 22:57:12 +0530
committerAnand Avati <avati@redhat.com>2013-08-21 12:13:50 -0700
commit9cef2810909cf260762b7b9837c5a9fa67f8033c (patch)
tree9a3262128c4081f523da1b0045955c193a3d3758 /xlators/features/gfid-access/src/Makefile.am
parentdf9bfff8ea08176a3874fb0cdec8fd4b988d3ffa (diff)
gfid-access: virtual access to filesystem through gfid path
BUG: 952029 Change-Id: I7405d473d369a4a951836eceda4faccbad19ce0e Signed-off-by: Amar Tumballi <amarts@redhat.com> Reviewed-on: http://review.gluster.org/5497 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Anand Avati <avati@redhat.com>
Diffstat (limited to 'xlators/features/gfid-access/src/Makefile.am')
-rw-r--r--xlators/features/gfid-access/src/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/xlators/features/gfid-access/src/Makefile.am b/xlators/features/gfid-access/src/Makefile.am
new file mode 100644
index 00000000000..db53affaab3
--- /dev/null
+++ b/xlators/features/gfid-access/src/Makefile.am
@@ -0,0 +1,15 @@
+xlator_LTLIBRARIES = gfid-access.la
+xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/features
+
+gfid_access_la_LDFLAGS = -module -avoid-version
+
+gfid_access_la_SOURCES = gfid-access.c
+gfid_access_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+
+noinst_HEADERS = gfid-access.h gfid-access-mem-types.h
+
+AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src
+
+AM_CFLAGS = -Wall $(GF_CFLAGS)
+
+CLEANFILES =