summaryrefslogtreecommitdiffstats
path: root/xlators/features/compress/src/Makefile.am
diff options
context:
space:
mode:
authorHarshavardhana <harsha@harshavardhana.net>2014-08-19 18:24:23 -0700
committerHarshavardhana <harsha@harshavardhana.net>2014-08-29 09:13:02 -0700
commit2dd53eb4de91c25817af85475cfa9ff66e79c97b (patch)
tree1fce885b03af9a07d797dfac92f9ecd24817617e /xlators/features/compress/src/Makefile.am
parent04be6a47df5c7d5c04c84fed06df9a8a1652c582 (diff)
porting: various fixes regression tests OSX/FreeBSD
- `wc -l` on OSX/FreeBSD adds spurious spaces, this clobbers up TAP output parsers - fix it. - `umount -l` doesn't exist on OSX/FreeBSD use 'umount -f' if available. - Add check for 'file' version, to handle mime type variations across versions - Converge 'glusterfs --attribute-timeout=0 --entry-timeout=0' into '$GFS' - Modify remaining 'mount -t nfs' to use 'mount_nfs' - Update sha1sum for OSX to use 'openssl sha1'. Change-Id: Id1012faa5d67a921513d220e7fa9cebafe830d34 BUG: 1131713 Signed-off-by: Harshavardhana <harsha@harshavardhana.net> Reviewed-on: http://review.gluster.org/8501 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Diffstat (limited to 'xlators/features/compress/src/Makefile.am')
-rw-r--r--xlators/features/compress/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/xlators/features/compress/src/Makefile.am b/xlators/features/compress/src/Makefile.am
index e69dc6bf236..4a4c8b1a8dd 100644
--- a/xlators/features/compress/src/Makefile.am
+++ b/xlators/features/compress/src/Makefile.am
@@ -7,7 +7,7 @@ noinst_HEADERS = cdc.h cdc-mem-types.h
cdc_la_LDFLAGS = -module -avoid-version
cdc_la_SOURCES = cdc.c cdc-helper.c
-cdc_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la $(LIBZ_LIBS)
+cdc_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la $(ZLIB_LIBS)
AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src -fPIC -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D$(GF_HOST_OS) \
-shared $(LIBZ_CFLAGS)