summaryrefslogtreecommitdiffstats
path: root/xlators/features/cloudsync/src/Makefile.am
diff options
context:
space:
mode:
authorNiels de Vos <ndevos@redhat.com>2018-08-09 15:52:19 +0200
committerAmar Tumballi <amarts@redhat.com>2018-08-30 05:41:26 +0000
commit44e40404ed1223ba9ccb879373da38efd5ba403c (patch)
treedcf7abb412ee5ad2280ede11872ce96ea36f1ac9 /xlators/features/cloudsync/src/Makefile.am
parentd27e8870c1882b1abfffefaf7b40bc7f2a1ec05f (diff)
build: add --enable-asan configure options
Introduce a `./configure --enable-asan` to build with `-fsanitize=address -fno-omit-frame-pointer` options. This uses the libasan.so shared library, so that needs to be available. While running builds with the ASAN options, several linker issues surfaced and these have been addressed with this change as well. Building with --enable-asan has been tested on Fedora 28. Change-Id: I428a9da70dd8f7d0056cfbe5c398619a571469b2 Updates: #492 Signed-off-by: Niels de Vos <ndevos@redhat.com>
Diffstat (limited to 'xlators/features/cloudsync/src/Makefile.am')
-rw-r--r--xlators/features/cloudsync/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/xlators/features/cloudsync/src/Makefile.am b/xlators/features/cloudsync/src/Makefile.am
index 0f3381f1d7d..0c3966c968b 100644
--- a/xlators/features/cloudsync/src/Makefile.am
+++ b/xlators/features/cloudsync/src/Makefile.am
@@ -21,7 +21,7 @@ cloudsync_la_SOURCES = $(cloudsync_sources) $(cloudsynccommon_sources)
nodist_cloudsync_la_SOURCES = cloudsync-autogen-fops.c cloudsync-autogen-fops.h
BUILT_SOURCES = cloudsync-autogen-fops.h
-cloudsync_la_LDFLAGS = -module $(GF_XLATOR_DEFAULT_LDFLAGS)
+cloudsync_la_LDFLAGS = $(LIB_DL) -module $(GF_XLATOR_DEFAULT_LDFLAGS)
cloudsync_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la