summaryrefslogtreecommitdiffstats
path: root/xlators/features/changetimerecorder/src/Makefile.am
diff options
context:
space:
mode:
authorMohammed Rafi KC <rkavunga@redhat.com>2015-03-20 19:28:22 +0530
committerKaleb KEITHLEY <kkeithle@redhat.com>2015-03-20 09:47:57 -0700
commit24e01e407a04db4983e45fc5338e4a732df7da28 (patch)
tree9f297294210faa8576b91c4b3dd1a4e7f28d24b0 /xlators/features/changetimerecorder/src/Makefile.am
parentf10dd13a285adb287fda452f9f3557f35ba178e1 (diff)
tiering/CTR:build CTR only if tiering is enabled
Thanks to Niels for this fix Change-Id: I9a13c3de3ed5d4eb06c6af61a2519bf27f1b6259 BUG: 1194753 Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com> Reviewed-on: http://review.gluster.org/9957 Reviewed-by: Niels de Vos <ndevos@redhat.com> Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Diffstat (limited to 'xlators/features/changetimerecorder/src/Makefile.am')
-rw-r--r--xlators/features/changetimerecorder/src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/xlators/features/changetimerecorder/src/Makefile.am b/xlators/features/changetimerecorder/src/Makefile.am
index 62664e8ebd4..128227a83d6 100644
--- a/xlators/features/changetimerecorder/src/Makefile.am
+++ b/xlators/features/changetimerecorder/src/Makefile.am
@@ -1,6 +1,10 @@
-xlator_LTLIBRARIES = changetimerecorder.la
xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/features
+# changetimerecorder can only get build when libgfdb is enabled
+if BUILD_GFDB
+ xlator_LTLIBRARIES = changetimerecorder.la
+endif
+
changetimerecorder_la_LDFLAGS = -module -avoid-version
changetimerecorder_la_SOURCES = changetimerecorder.c ctr-helper.c