summaryrefslogtreecommitdiffstats
path: root/xlators/features/bit-rot/src/bitd/Makefile.am
diff options
context:
space:
mode:
authorVenky Shankar <vshankar@redhat.com>2015-06-09 10:02:11 +0530
committerRaghavendra Bhat <raghavendra@redhat.com>2015-06-25 05:57:22 -0700
commit913631a0edffaefc0fae73df46f80e19422ebed9 (patch)
tree9be7034a4cb95bb368d948c673278e6bd150d488 /xlators/features/bit-rot/src/bitd/Makefile.am
parentf1139ca4f8532c35f5f8024610ddc5a412f970e8 (diff)
features/bitrot: handle scrub states via state machine
A bunch of command line options for scrubber tempted the use of state machine to track current state of scrubber under various circumstances where the options could be in effect. Change-Id: Id614bb2e6af30a90d2391ea31ae0a3edeb4e0d69 BUG: 1231619 Signed-off-by: Venky Shankar <vshankar@redhat.com> Reviewed-on: http://review.gluster.org/11149 Tested-by: NetBSD Build System <jenkins@build.gluster.org> Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com> Tested-by: Gluster Build System <jenkins@build.gluster.com>
Diffstat (limited to 'xlators/features/bit-rot/src/bitd/Makefile.am')
-rw-r--r--xlators/features/bit-rot/src/bitd/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/xlators/features/bit-rot/src/bitd/Makefile.am b/xlators/features/bit-rot/src/bitd/Makefile.am
index fd42ebe5a72..154cdfba674 100644
--- a/xlators/features/bit-rot/src/bitd/Makefile.am
+++ b/xlators/features/bit-rot/src/bitd/Makefile.am
@@ -9,11 +9,11 @@ AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src \
-I$(CONTRIBDIR)/timer-wheel \
-I$(top_srcdir)/xlators/features/bit-rot/src/stub
-bit_rot_la_SOURCES = bit-rot.c bit-rot-scrub.c bit-rot-tbf.c
+bit_rot_la_SOURCES = bit-rot.c bit-rot-scrub.c bit-rot-tbf.c bit-rot-ssm.c
bit_rot_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la \
$(top_builddir)/xlators/features/changelog/lib/src/libgfchangelog.la
-noinst_HEADERS = bit-rot.h bit-rot-scrub.h bit-rot-tbf.h bit-rot-bitd-messages.h
+noinst_HEADERS = bit-rot.h bit-rot-scrub.h bit-rot-tbf.h bit-rot-bitd-messages.h bit-rot-ssm.h
AM_CFLAGS = -Wall $(GF_CFLAGS)