summaryrefslogtreecommitdiffstats
path: root/xlators/features/Makefile.am
diff options
context:
space:
mode:
authorSusant Palai <spalai@redhat.com>2018-05-22 19:55:27 +0530
committerAmar Tumballi <amarts@redhat.com>2018-05-30 03:26:25 +0000
commit62990c30fcec37f643b7631070de8baba276f0ba (patch)
tree14c46a3b15eacc3df318337da1e8a7d954efbfc6 /xlators/features/Makefile.am
parentcb4e0fa2cbd25ef4ab5b65c6a76a6aea90c0f835 (diff)
cloudsync: Adding s3 plugin for cloudsync
This is a plugin which provides an interface to retrive files from amazon-s3 which are archived in to s3. Users need to give the above information for cloudsync to retrieve the file from s3. TODO: 1- A separate commit in to developer-guide will detail about the usage of this plugin in more detail. 2- Need to create target file in aws-bucket with "gfid" names. Helps avoiding name collisions. Change-Id: I2e4a586f4e3f86164de9178e37673a07f317e7d9 Updates: #387 Signed-off-by: Susant Palai <spalai@redhat.com>
Diffstat (limited to 'xlators/features/Makefile.am')
-rw-r--r--xlators/features/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/xlators/features/Makefile.am b/xlators/features/Makefile.am
index 81fbe856e78..6ef19af0860 100644
--- a/xlators/features/Makefile.am
+++ b/xlators/features/Makefile.am
@@ -1,6 +1,11 @@
+if BUILD_CLOUDSYNC
+ CLOUDSYNC_DIR = cloudsync
+endif
+
+
SUBDIRS = locks quota read-only quiesce marker index barrier \
arbiter compress changelog changetimerecorder \
gfid-access $(GLUPY_SUBDIR) upcall snapview-client snapview-server \
- trash shard bit-rot leases selinux sdfs namespace cloudsync thin-arbiter \
+ trash shard bit-rot leases selinux sdfs namespace $(CLOUDSYNC_DIR) thin-arbiter \
utime
CLEANFILES =