summaryrefslogtreecommitdiffstats
path: root/xlators/features/Makefile.am
diff options
context:
space:
mode:
authorKotresh HR <khiremat@redhat.com>2018-04-30 04:43:58 -0400
committerAmar Tumballi <amarts@redhat.com>2018-05-06 07:09:18 +0530
commit487aaafacac8af16c08eb44fe9bf178768d372fa (patch)
tree69a8ff6a8be0f40e129a71bf28ef5e4a558d5109 /xlators/features/Makefile.am
parentf8fe0771f0b450713595a7d298ed5a758cf2ce3e (diff)
utime: ctime client side xlator
The client side utime xlator does two things. 1. Update unix epoch time in frame->root->ctime 2. Update the frame->root->flags based on the fop which indicates time attributes that should be updated for the parent/entry. Credits: Rafi KC <rkavunga@redhat.com> Updates: #208 Change-Id: I9cad297040c70798a0a8468a080eb4aeff73138d Signed-off-by: Kotresh HR <khiremat@redhat.com>
Diffstat (limited to 'xlators/features/Makefile.am')
-rw-r--r--xlators/features/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/xlators/features/Makefile.am b/xlators/features/Makefile.am
index a8d73c83b83..81fbe856e78 100644
--- a/xlators/features/Makefile.am
+++ b/xlators/features/Makefile.am
@@ -1,5 +1,6 @@
SUBDIRS = locks quota read-only quiesce marker index barrier \
arbiter compress changelog changetimerecorder \
gfid-access $(GLUPY_SUBDIR) upcall snapview-client snapview-server \
- trash shard bit-rot leases selinux sdfs namespace cloudsync thin-arbiter
+ trash shard bit-rot leases selinux sdfs namespace cloudsync thin-arbiter \
+ utime
CLEANFILES =