summaryrefslogtreecommitdiffstats
path: root/xlators/experimental/fdl/src/Makefile.am
diff options
context:
space:
mode:
authorKaushal M <kaushal@redhat.com>2016-10-28 15:55:55 +0530
committerPranith Kumar Karampuri <pkarampu@redhat.com>2016-11-13 21:27:04 -0800
commit82b29e0de686b7bd9f36ddf49376fc07f0c42125 (patch)
tree896fbb62144aa771a2e45d8dec80db1685919c17 /xlators/experimental/fdl/src/Makefile.am
parent72ce732fa5c9979ea6352ea98451471b721410c1 (diff)
Remove experimental translators
Change-Id: Id645918fa236f1fc00ab5fa427f394e853c44bf8 BUG: 1389675 Signed-off-by: Kaushal M <kaushal@redhat.com> Reviewed-on: http://review.gluster.org/15750 Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com> Smoke: Gluster Build System <jenkins@build.gluster.org> NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org> CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
Diffstat (limited to 'xlators/experimental/fdl/src/Makefile.am')
-rw-r--r--xlators/experimental/fdl/src/Makefile.am43
1 files changed, 0 insertions, 43 deletions
diff --git a/xlators/experimental/fdl/src/Makefile.am b/xlators/experimental/fdl/src/Makefile.am
deleted file mode 100644
index aed0204284f..00000000000
--- a/xlators/experimental/fdl/src/Makefile.am
+++ /dev/null
@@ -1,43 +0,0 @@
-xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/experimental
-xlator_LTLIBRARIES = fdl.la
-
-noinst_HEADERS = jnl-types.h
-
-nodist_fdl_la_SOURCES = fdl.c
-fdl_la_LDFLAGS = -module -avoid-version
-fdl_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
-
-sbin_PROGRAMS = gf_logdump gf_recon
-gf_logdump_SOURCES = logdump.c
-nodist_gf_logdump_SOURCES = libfdl.c
-gf_logdump_LDADD = $(top_builddir)/libglusterfs/src/libglusterfs.la\
- $(top_builddir)/api/src/libgfapi.la
-
-# Eventually recon(ciliation) code will move elsewhere, but for now it's
-# easier to have it next to the similar logdump code.
-gf_recon_SOURCES = recon.c
-nodist_gf_recon_SOURCES = librecon.c
-gf_recon_LDADD = $(top_builddir)/libglusterfs/src/libglusterfs.la\
- $(top_builddir)/api/src/libgfapi.la
-
-AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src \
- -I$(top_srcdir)/api/src -fPIC \
- -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -D$(GF_HOST_OS) \
- -DDATADIR=\"$(localstatedir)\"
-
-AM_CFLAGS = -Wall $(GF_CFLAGS)
-
-noinst_PYTHON = gen_fdl.py gen_dumper.py gen_recon.py
-EXTRA_DIST = fdl-tmpl.c dump-tmpl.c recon-tmpl.c
-
-CLEANFILES = $(nodist_fdl_la_SOURCES) $(nodist_gf_logdump_SOURCES) \
- $(nodist_gf_recon_SOURCES)
-
-fdl.c: fdl-tmpl.c gen_fdl.py
- $(PYTHON) $(srcdir)/gen_fdl.py $(srcdir)/fdl-tmpl.c > $@
-
-libfdl.c: dump-tmpl.c gen_dumper.py
- $(PYTHON) $(srcdir)/gen_dumper.py $(srcdir)/dump-tmpl.c > $@
-
-librecon.c: recon-tmpl.c gen_recon.py
- $(PYTHON) $(srcdir)/gen_recon.py $(srcdir)/recon-tmpl.c > $@