summaryrefslogtreecommitdiffstats
path: root/xlators/debug/io-stats/src/Makefile.am
diff options
context:
space:
mode:
authorCsaba Henk <csaba@zresearch.com>2009-04-28 10:22:03 +0000
committerAnand V. Avati <avati@dev.gluster.com>2009-05-20 12:33:25 -0700
commit5bb6653c434c74b5f2d5b706f60f8d4149a40a2d (patch)
tree6bd07c7580bb1a46492de5bbd875edc8cadf9a69 /xlators/debug/io-stats/src/Makefile.am
parentd734a305d534d6430d1401ec358100f28547ca09 (diff)
add xlator debug/io-stats
Signed-off-by: Anand V. Avati <avati@dev.gluster.com>
Diffstat (limited to 'xlators/debug/io-stats/src/Makefile.am')
-rw-r--r--xlators/debug/io-stats/src/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/xlators/debug/io-stats/src/Makefile.am b/xlators/debug/io-stats/src/Makefile.am
new file mode 100644
index 00000000000..91aea6ebbc2
--- /dev/null
+++ b/xlators/debug/io-stats/src/Makefile.am
@@ -0,0 +1,13 @@
+
+xlator_LTLIBRARIES = io-stats.la
+xlatordir = $(libdir)/glusterfs/$(PACKAGE_VERSION)/xlator/debug
+
+io_stats_la_LDFLAGS = -module -avoidversion
+
+io_stats_la_SOURCES = io-stats.c
+io_stats_la_LIBADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+
+AM_CFLAGS = -fPIC -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE -Wall -D$(GF_HOST_OS)\
+ -I$(top_srcdir)/libglusterfs/src -shared -nostartfiles $(GF_CFLAGS)
+
+CLEANFILES =