summaryrefslogtreecommitdiffstats
path: root/xlators/cluster/dht/src/Makefile.am
diff options
context:
space:
mode:
authorEmmanuel Dreyfus <manu@netbsd.org>2014-07-27 08:45:50 +0200
committerHarshavardhana <harsha@harshavardhana.net>2014-07-27 11:57:24 -0700
commit5986d22e621e0c682f319bb6a0a8e622a8c0970d (patch)
treea46bcdeeaf475f5121ab18abd5ffe1f98b0eb6a6 /xlators/cluster/dht/src/Makefile.am
parent35c6ca05d8ee0e1be1b67ac64d32c21b195aaeea (diff)
Attempt to fix cmockery2 build
The current code assumes cmockery2 is installed in default paths. Use PKG_MODULES_CHECK to find it using pkg-config if it is not. If not found by pkg-config, try AC_CHECK_LIB. There are also some build flag adjustement so that local overrides do not loose the required -I flags. This includes and enhance http://review.gluster.org/8340/ BUG: 764655 Change-Id: Ide9f77d1e70afe3c1c5c57ae2b93127af6a425f9 Signed-off-by: Emmanuel Dreyfus <manu@netbsd.org> Reviewed-on: http://review.gluster.org/8365 Reviewed-by: Harshavardhana <harsha@harshavardhana.net> Tested-by: Harshavardhana <harsha@harshavardhana.net> Tested-by: Gluster Build System <jenkins@build.gluster.com>
Diffstat (limited to 'xlators/cluster/dht/src/Makefile.am')
-rw-r--r--xlators/cluster/dht/src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/xlators/cluster/dht/src/Makefile.am b/xlators/cluster/dht/src/Makefile.am
index 9b5d6897984..46a2bcd06b8 100644
--- a/xlators/cluster/dht/src/Makefile.am
+++ b/xlators/cluster/dht/src/Makefile.am
@@ -45,7 +45,7 @@ dht_layout_unittest_CPPFLAGS = $(AM_CPPFLAGS)
dht_layout_unittest_SOURCES = unittest/dht_layout_unittest.c \
unittest/dht_layout_mock.c \
dht-layout.c
-dht_layout_unittest_CFLAGS = $(UNITTEST_CFLAGS)
+dht_layout_unittest_CFLAGS = $(AM_CFLAGS) $(UNITTEST_CFLAGS)
dht_layout_unittest_LDFLAGS = $(UNITTEST_LDFLAGS)
noinst_PROGRAMS += dht_layout_unittest
TESTS += dht_layout_unittest