summaryrefslogtreecommitdiffstats
path: root/tools/glusterfind/Makefile.am
diff options
context:
space:
mode:
authorEmmanuel Dreyfus <manu@netbsd.org>2015-04-16 19:28:21 +0200
committerVijay Bellur <vbellur@redhat.com>2015-04-20 04:29:26 -0700
commit1fbcecb72ef3525823536b640d244d1e5127a37f (patch)
tree9f028db0ff61ce4c262d0cc26992eeddbc5c5680 /tools/glusterfind/Makefile.am
parentf45779067dbba3077b9c64c930fd4ddd1c51243e (diff)
Fix case mistake for MKDIR_P in Makefiles
Some makefiles used $(mkdir_p) instead of the corectly defined $(MKDIR_P). The former is substituted as an empty string, leading to possible failures depending of the user shell tolerance. NetBSD's /bin/sh seems to choke more easily than Linux's /bin/bash, but if the later does not fail, it does not created the intended directories anyway. BUG: 1129939 Change-Id: I8caed4000f3c91cb3a685453848fb854793945ed Signed-off-by: Emmanuel Dreyfus <manu@netbsd.org> Reviewed-on: http://review.gluster.org/10276 Tested-by: NetBSD Build System Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Niels de Vos <ndevos@redhat.com>
Diffstat (limited to 'tools/glusterfind/Makefile.am')
-rw-r--r--tools/glusterfind/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tools/glusterfind/Makefile.am b/tools/glusterfind/Makefile.am
index 872fff12047..c5a05d61061 100644
--- a/tools/glusterfind/Makefile.am
+++ b/tools/glusterfind/Makefile.am
@@ -7,4 +7,4 @@ bin_SCRIPTS = glusterfind
CLEANFILES = $(bin_SCRIPTS)
install-data-local:
- $(mkdir_p) $(DESTDIR)$(GLUSTERD_WORKDIR)/glusterfind/.keys
+ $(MKDIR_P) $(DESTDIR)$(GLUSTERD_WORKDIR)/glusterfind/.keys