summaryrefslogtreecommitdiffstats
path: root/tools/gfind_missing_files/Makefile.am
diff options
context:
space:
mode:
authorKaleb S. KEITHLEY <kkeithle@redhat.com>2015-07-02 12:43:09 -0400
committerKaleb KEITHLEY <kkeithle@redhat.com>2015-07-05 13:03:19 -0700
commit0fdf6c9db5114c77cd846c71699eb877d41ad6ae (patch)
treecba5c252006d162ce2dc3431bc1464b2d1f50df8 /tools/gfind_missing_files/Makefile.am
parent78232678ad45cf8d12b991ea1ff441fbcdc3a601 (diff)
build: Mac OS X build issues, no spinlock, need sys_lgetxattr
use regular locks, use our syscall wrappers in libglusterfs Change-Id: I7e0d00956366806af041b69b65d1f169aa0d2ae2 BUG: 1238793 Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com> Reviewed-on: http://review.gluster.org/11515 Tested-by: Gluster Build System <jenkins@build.gluster.com> Reviewed-by: Niels de Vos <ndevos@redhat.com> Tested-by: NetBSD Build System <jenkins@build.gluster.org>
Diffstat (limited to 'tools/gfind_missing_files/Makefile.am')
-rw-r--r--tools/gfind_missing_files/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tools/gfind_missing_files/Makefile.am b/tools/gfind_missing_files/Makefile.am
index 456aad836b6..043c34c4182 100644
--- a/tools/gfind_missing_files/Makefile.am
+++ b/tools/gfind_missing_files/Makefile.am
@@ -9,6 +9,8 @@ EXTRA_DIST = gfind_missing_files.sh gfid_to_path.sh \
gfindmissingfiles_PROGRAMS = gcrawler
gcrawler_SOURCES = gcrawler.c
+gcrawler_LDADD = $(top_builddir)/libglusterfs/src/libglusterfs.la
+gcrawler_LDFLAGS = $(GF_LDFLAGS)
AM_CPPFLAGS = $(GF_CPPFLAGS) -I$(top_srcdir)/libglusterfs/src